Italian community of Lazarus and Free Pascal

Installare lazarus su mac osx sierra

Per installare lazarus con il debugger gdb su mac os sierra bisogna seguire la seguente trafila.
1. Avviare il sistema operativo in recovery mode "command + R"
2. Aprire utility->terminale e digitare: csrutil disable
3. Riavviare il sistema operativo normalmente, aprire un terminale e digitare: brew install gdb
4. Creare un certificato prendo il portachiavi -> (menu) accesso portachiavi -> assistente certificato -> crea un certificato
Popolare i campi così:
Nome: mygdb-cert
Tipo d'identità: Primo livello autofirmato
Tipo certificato: Firma codice
Flaggare "Lascia che sia io a sovascrivere i default"

Poi dai continua (modifica il periodi di validità a 999) poi continua senza modificare nulla fino a quando non ti compare la scritta "Specifica un portachiavi in cui inserire il certificato" e allora imposti "Sistema"

Premi il pulsante crea e poi fine.
Ora ti compare un certificato di nome mygdb-cert sulla finestra dei portachiavi (in sistema) fai doppio click sopra e cambia "Quando si usa questo certificato" in modo che sia "Fidati sempre".

Riavvia il sistema operativo normalmente

Apriamo un terminale e digitiamo: codesign -f -s "mygdb-cert" /usr/local/Cellar/gdb/7.12_1/bin/gdb

Ovvero abbiamo firmato il gdb con il certificato appena generato.
Ora scarichiamo lazarus dal sito ufficiale (compreso di fpc e sorgenti fpc) e installiamolo normalmente

Assicuriamoci che il gdb che vogliamo far usare al nostro lazarus sia /usr/local/Cellar/gdb/7.12_1/bin/gdb
ovvero quello installato da homebrew.

Riavviamo il mac in recovery mode (command + R) apriamo utility->terminale e digitiamo: csrutil enable --without debug


Riavviamo il sistema operativo normalmente e ora possiamo goderci il nostro lazarus

EDIT: nel caso vogliate installare lazarus con i widgets cocoa vi consiglio di utilizzare fpcupdeluxe ovviamente dovete scaricare l'eseguibile rilasciato per cocoa a 64 bit. Installate la versione trunk di fpc e la versione trunk di lazarus così da avere la 1.9.0 installata (che rilascia i widgets cocoa il più aggiornati possibili, attenzione sono stati introdotti da poco e qualcosa potrebbe non funzionare). Fatto questo quando lanciate lazarus potrebbe darvi l'errore Arithmetic overflow. In questo caso spostatevi nella cartella in cui avete installato lazarus con fpcupdeluxe attraverso un terminale e lanciate i tre comandi che seguono:

lazbuild --build-ide="Normal IDE"
make clean all
make LCL_PLATFORM=cocoa


Adesso dovrebbe funzionare tutto. Questo edit finale all'articolo serve solo fino a quando l'ambiente lazarus/cocoa non sarà adeguatamente maturo. Parlando con l'autore direi che ci vorrà ancora un annetto (ad oggi estate 2018) per poter considerare lazarus/cocoa maturo in tutti i suoi aspetti. Ma già ad oggi è possibile lavorarci dignitosamente.


Navigazione

[0] How to

[#] Forum

Vai alla versione completa